Skip to content

← Actionable
High, CVSS 7.5amended

Directus crashes on invalid WebSocket message

CVE-2023-45820GHSA-hmgw-9jrg-hf2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 10.4.0, < 10.6.2
    Fixed in
    10.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-45820: 0.83% estimated exploitation activity in the next 30 days; percentile 57.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It seems that any Directus installation that has websockets enabled can be crashed if the websocket server receives an invalid frame. This could probably be posted as an issue and I might even be able to put together a pull request for a fix (if only I had some extra time...), but I decided to instead post as a vulnerability just for the maintainers, since this seemingly can be used to crash any live Directus server if websockets are enabled, so public disclosure is not a good idea until the issue is fixed. Details The fix for this seems quite simple; the websocket server just needs to properly catch the error instead of crashing the server. See for example: https://github.com/websockets/ws/issues/2098 PoC - Start a fresh Directus server (using for example the compose file here: https://docs.directus.io/self-hosted/docker-guide.html). Enable websockets by setting WEBSOCKETSENABLED: 'true' environment variable. - run a separate node app somewhere else to send an invalid frame…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hmgw-9jrg-hf2m

  2. Revision 1 · created ·

    Published from osv record GHSA-hmgw-9jrg-hf2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-45820

Advisory: Directus crashes on invalid WebSocket message
IDs: CVE-2023-45820, GHSA-hmgw-9jrg-hf2m
Record: https://patchnext.com/advisories/cve-2023-45820 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 10.4.0, < 10.6.2; fixed in 10.6.2

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hmgw-9jrg-hf2m (OSV record GHSA-hmgw-9jrg-hf2m lists affected ranges: npm directus >=10.4.0 <10.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-hmgw-9jrg-hf2m (GitHub-reviewed advisory GHSA-hmgw-9jrg-hf2m lists affected ranges: npm directus >=10.4.0 <10.6.2)

Commands are suggestions: review each one before running it.

Loading voting…