TinyMCE mXSS vulnerability in undo/redo, getContent API, resetContent API, and Autosave plugin
CVE-2023-45818GHSA-v65r-p3vv-jjfv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 6.7.1, 5.10.8; tinymce/tinymce 6.7.1, 5.10.8; tinymce 6.7.1, 5.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet tinymce
- Affected
- >= 6.0.0, < 6.7.1< 5.10.8
- Fixed in
- 5.10.8, 6.7.1
Packagist tinymce/tinymce
- Affected
- >= 6.0.0, < 6.7.1< 5.10.8
- Fixed in
- 5.10.8, 6.7.1
npm tinymce
- Affected
- >= 6.0.0, < 6.7.1< 5.10.8
- Fixed in
- 5.10.8, 6.7.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v65r-p3vv-jjfv lists affected ranges: npm tinymce >=6.0.0 =0 =6.0.0 =0 =6.0.0 =0 <5.10.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v65r-p3vv-jjfv lists affected ranges: npm tinymce >=6.0.0 =0 =6.0.0 =0 =6.0.0 =0 <5.10.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-45818: 0.76% estimated exploitation activity in the next 30 days; percentile 55.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo and redo functionality. When a carefully-crafted HTML snippet passes the XSS sanitisation layer, it is manipulated as a string by internal trimming functions before being stored in the undo stack. If the HTML snippet is restored from the undo stack, the combination of the string manipulation and reparative parsing by either the browser's native DOMParser API (TinyMCE 6) or the SaxParser API (TinyMCE 5) mutates the HTML maliciously, allowing an XSS payload to be executed. This vulnerability also impacts these related TinyMCE APIs and plugins: tinymce.Editor.getContent({ format: 'raw' }) tinymce.Editor.resetContent() Autosave Plugin Patches This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring HTML is trimmed using node-level manipulation instead of string manipulation. Fix To avoid this vulnerability: Upgrade to TinyMCE 5.10.8 or higher for TinyMCE 5.x.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v65r-p3vv-jjfv
- Revision 1 · created ·
Published from osv record GHSA-v65r-p3vv-jjfv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-45818 Advisory: TinyMCE mXSS vulnerability in undo/redo, getContent API, resetContent API, and Autosave plugin IDs: CVE-2023-45818, GHSA-v65r-p3vv-jjfv Record: https://patchnext.com/advisories/cve-2023-45818 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tinymce 6.7.1, 5.10.8; tinymce/tinymce 6.7.1, 5.10.8; tinymce 6.7.1, 5.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet tinymce: affected >= 6.0.0, < 6.7.1; < 5.10.8; fixed in 5.10.8, 6.7.1 - Packagist tinymce/tinymce: affected >= 6.0.0, < 6.7.1; < 5.10.8; fixed in 5.10.8, 6.7.1 - npm tinymce: affected >= 6.0.0, < 6.7.1; < 5.10.8; fixed in 5.10.8, 6.7.1 ## Suggested inspection (read-only) - NuGet tinymce: check the installed version with your package manager. - Packagist tinymce/tinymce: check the installed version with your package manager. - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce, tinymce/tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v65r-p3vv-jjfv (OSV record GHSA-v65r-p3vv-jjfv lists affected ranges: npm tinymce >=6.0.0 =0 =6.0.0 =0 =6.0.0 =0 <5.10.8 (fixed)) - Verified: https://github.com/advisories/GHSA-v65r-p3vv-jjfv (GitHub-reviewed advisory GHSA-v65r-p3vv-jjfv lists affected ranges: npm tinymce >=6.0.0 =0 =6.0.0 =0 =6.0.0 =0 <5.10.8) Commands are suggestions: review each one before running it.
Loading voting…