Apollo Router vulnerable to Improper Check or Handling of Exceptional Conditions
CVE-2023-45812GHSA-r344-xw3p-2frj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-router 1.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io apollo-router
- Affected
- >= 1.31.0, < 1.33.0
- Fixed in
- 1.33.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r344-xw3p-2frj lists affected ranges: crates.io apollo-router >=1.31.0 <1.33.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-45812: 0.87% estimated exploitation activity in the next 30 days; percentile 58.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Apollo Router is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation. Affected versions are subject to a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when a multi-part response is sent. When users send queries to the router that uses the @defer or Subscriptions, the Router will panic. To be vulnerable, users of Router must have a coprocessor with coprocessor.supergraph.response configured in their router.yaml and also to support either @defer or Subscriptions. Patches Router version 1.33.0 has a fix for this vulnerability. https://github.com/apollographql/router/pull/4014 fixes the issue. Workarounds For affected versions, avoid using the coprocessor supergraph response: Or you can disable defer and subscriptions support: and continue to use the coprocessor supergraph response. References https://github.com/apollographql/router/issues/4013
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r344-xw3p-2frj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-45812 Advisory: Apollo Router vulnerable to Improper Check or Handling of Exceptional Conditions IDs: CVE-2023-45812, GHSA-r344-xw3p-2frj Record: https://patchnext.com/advisories/cve-2023-45812 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apollo-router 1.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io apollo-router: affected >= 1.31.0, < 1.33.0; fixed in 1.33.0 ## Suggested inspection (read-only) - crates.io apollo-router: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apollo-router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r344-xw3p-2frj (GitHub-reviewed advisory GHSA-r344-xw3p-2frj lists affected ranges: crates.io apollo-router >=1.31.0 <1.33.0) Commands are suggestions: review each one before running it.
Loading voting…