Skip to content

← Actionable
Low, CVSS 2.7amended

Wagtail vulnerable to disclosure of user names via admin bulk action views

CVE-2023-45809GHSA-fc75-58r8-rm3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 5.1.3, 5.0.5, 4.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 4.1.9>= 4.2.0, < 5.0.5>= 5.1.0, < 5.1.3
    Fixed in
    4.1.9, 5.1.3, 5.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-45809: 0.56% estimated exploitation activity in the next 30 days; percentile 46.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user with a limited-permission editor account for the Wagtail admin can make a direct URL request to the admin view that handles bulk actions on user accounts. While authentication rules prevent the user from making any changes, the error message discloses the display names of user accounts, and by modifying URL parameters, the user can retrieve the display name for any user. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 4.1.9 (LTS), 5.0.5 and 5.1.3. The fix is also included in Release Candidate 1 of the forthcoming Wagtail 5.2 release. Workarounds None. Acknowledgements Many thanks to @quyenheu for reporting this issue. For more information If you have any questions or comments about this advisory: Visit Wagtail's support channels Email us at security@wagtail.org (view our security policy for more information).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fc75-58r8-rm3h

  2. Revision 1 · created ·

    Published from osv record GHSA-fc75-58r8-rm3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-45809

Advisory: Wagtail vulnerable to disclosure of user names via admin bulk action views
IDs: CVE-2023-45809, GHSA-fc75-58r8-rm3h
Record: https://patchnext.com/advisories/cve-2023-45809 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 5.1.3, 5.0.5, 4.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 4.1.9; >= 4.2.0, < 5.0.5; >= 5.1.0, < 5.1.3; fixed in 4.1.9, 5.1.3, 5.0.5

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fc75-58r8-rm3h (OSV record GHSA-fc75-58r8-rm3h lists affected ranges: PyPI wagtail >=0 =4.2.0 =5.1.0 <5.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-fc75-58r8-rm3h (GitHub-reviewed advisory GHSA-fc75-58r8-rm3h lists affected ranges: PyPI wagtail >=0 =4.2.0 =5.1.0 <5.1.3)

Commands are suggestions: review each one before running it.

Loading voting…