OpenSearch Issue with tenant read-only permissions
CVE-2023-45807GHSA-72q2-gwwf-6hrv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.plugin:opensearch-security 2.11.0.0, 1.3.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opensearch.plugin:opensearch-security
- Affected
- >= 2.0.0.0, < 2.11.0.0< 1.3.14.0
- Fixed in
- 1.3.14.0, 2.11.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72q2-gwwf-6hrv lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=2.0.0.0 =0 <1.3.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2023-45807: 0.49% estimated exploitation activity in the next 30 days; percentile 41.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is an issue with the implementation of tenant permissions in OpenSearch Dashboards where authenticated users with read-only access to a tenant can perform create, edit and delete operations on index metadata of dashboards and visualizations in that tenant, potentially rendering them unavailable. This issue does not affect index data, only metadata. Dashboards correctly enforces read-only permissions when indexing and updating documents. This issue does not provide additional read access to data users don’t already have. Mitigation This issue can be mitigated by disabling the tenants functionality for the cluster. Versions 1.3.14 and 2.11.0 contain a fix for this issue. For more information If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72q2-gwwf-6hrv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-45807 Advisory: OpenSearch Issue with tenant read-only permissions IDs: CVE-2023-45807, GHSA-72q2-gwwf-6hrv Record: https://patchnext.com/advisories/cve-2023-45807 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opensearch.plugin:opensearch-security 2.11.0.0, 1.3.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opensearch.plugin:opensearch-security: affected >= 2.0.0.0, < 2.11.0.0; < 1.3.14.0; fixed in 1.3.14.0, 2.11.0.0 ## Suggested inspection (read-only) - Maven org.opensearch.plugin:opensearch-security: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opensearch.plugin:opensearch-security. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72q2-gwwf-6hrv (GitHub-reviewed advisory GHSA-72q2-gwwf-6hrv lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=2.0.0.0 =0 <1.3.14.0) Commands are suggestions: review each one before running it.
Loading voting…