Cross-site Scripting via missing Binding syntax validation
CVE-2023-45683GHSA-267v-3v32-g6q5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/crewjam/saml 0.4.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.4.14
- Fixed in
- 0.4.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-267v-3v32-g6q5 lists affected ranges: Go github.com/crewjam/saml >=0 <0.4.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2023-45683: 0.48% estimated exploitation activity in the next 30 days; percentile 41.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The package does not validate the ACS Location URI according to the SAML binding being parsed. If abused, this flaw allows attackers to register malicious Service Providers at the IdP and inject Javascript in the ACS endpoint definition, achieving Cross-Site-Scripting (XSS) in the IdP context during the redirection at the end of a SAML SSO Flow. Consequently, an attacker may perform any authenticated action as the victim once the victim’s browser loaded the SAML IdP initiated SSO link for the malicious service provider. Note: The severity is considered “High” because the SP registration is commonly an unrestricted operation in IdPs, hence not requiring particular permissions or publicly accessible to ease the IdP interoperability. Patches This issue is fixed in 0.4.14 Workarounds Users of the package can perform external validation of URLs provided in SAML metadata, or restrict the ability for end-users to upload arbitrary metadata. References This issue was reported by…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-267v-3v32-g6q5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-45683 Advisory: Cross-site Scripting via missing Binding syntax validation IDs: CVE-2023-45683, GHSA-267v-3v32-g6q5 Record: https://patchnext.com/advisories/cve-2023-45683 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/crewjam/saml 0.4.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/crewjam/saml: affected < 0.4.14; fixed in 0.4.14 ## Suggested inspection (read-only) - Go github.com/crewjam/saml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/crewjam/saml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-267v-3v32-g6q5 (GitHub-reviewed advisory GHSA-267v-3v32-g6q5 lists affected ranges: Go github.com/crewjam/saml >=0 <0.4.14) Commands are suggestions: review each one before running it.
Loading voting…