Apache Airflow vulnerable to sensitive information exposure when expose-config is set to non-sensitive-only
CVE-2023-45348GHSA-fpxx-xv4c-gxqp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 2.7.0, < 2.7.2
- Fixed in
- 2.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fpxx-xv4c-gxqp lists affected ranges: PyPI apache-airflow >=2.7.0 <2.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpxx-xv4c-gxqp lists affected ranges: PyPI apache-airflow >=2.7.0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-45348: 1.60% estimated exploitation activity in the next 30 days; percentile 75.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the exposeconfig option is set to non-sensitive-only. The exposeconfig option is False by default. It is recommended to upgrade to a version that is not affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fpxx-xv4c-gxqp
- Revision 1 · created ·
Published from osv record GHSA-fpxx-xv4c-gxqp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-45348 Advisory: Apache Airflow vulnerable to sensitive information exposure when expose-config is set to non-sensitive-only IDs: CVE-2023-45348, GHSA-fpxx-xv4c-gxqp Record: https://patchnext.com/advisories/cve-2023-45348 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 2.7.0, < 2.7.2; fixed in 2.7.2 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fpxx-xv4c-gxqp (OSV record GHSA-fpxx-xv4c-gxqp lists affected ranges: PyPI apache-airflow >=2.7.0 <2.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-fpxx-xv4c-gxqp (GitHub-reviewed advisory GHSA-fpxx-xv4c-gxqp lists affected ranges: PyPI apache-airflow >=2.7.0 <2.7.2) Commands are suggestions: review each one before running it.
Loading voting…