Skip to content

← Actionable
Critical, CVSS 10.0

XWiki Change Request Application UI XSS and remote code execution through change request title

CVE-2023-45138GHSA-f776-w9v2-7vfj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.contrib.changerequest:application-changerequest-ui 1.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-45138: 71.74% estimated exploitation activity in the next 30 days; percentile 99.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It's possible for a user without any specific right to perform script injection and remote code execution just by inserting an appropriate title when creating a new Change Request. This vulnerability is particularly critical as Change Request aims at being created by user without any particular rights. Patches The vulnerability has been fixed in Change Request 1.9.2. Workarounds It's possible to workaround the issue without upgrading by editing the document ChangeRequest.Code.ChangeRequestSheet and by performing the same change as in the commit: https://github.com/xwiki-contrib/application-changerequest/commit/7565e720117f73102f5a276239eabfe85e15cff4. References JIRA ticket: https://jira.xwiki.org/browse/CRAPP-298 Commit of the fix: https://github.com/xwiki-contrib/application-changerequest/commit/7565e720117f73102f5a276239eabfe85e15cff4 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f776-w9v2-7vfj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-45138

Advisory: XWiki Change Request Application UI XSS and remote code execution through change request title
IDs: CVE-2023-45138, GHSA-f776-w9v2-7vfj
Record: https://patchnext.com/advisories/cve-2023-45138 (revision 1, source checked 26 Oct 2026, 16:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.contrib.changerequest:application-changerequest-ui 1.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.contrib.changerequest:application-changerequest-ui: affected >= 0.11, < 1.9.2; fixed in 1.9.2

## Suggested inspection (read-only)
- Maven org.xwiki.contrib.changerequest:application-changerequest-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.contrib.changerequest:application-changerequest-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f776-w9v2-7vfj (GitHub-reviewed advisory GHSA-f776-w9v2-7vfj lists affected ranges: Maven org.xwiki.contrib.changerequest:application-changerequest-ui >=0.11 <1.9.2)

Commands are suggestions: review each one before running it.

Loading voting…