Skip to content

← Actionable
Critical, CVSS 9.3

Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code

CVE-2023-45133GHSA-67hx-6x53-jw92

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @babel/traverse

    Affected
    < 7.23.2>= 8.0.0-alpha.0, < 8.0.0-alpha.4
    Fixed in
    7.23.2, 8.0.0-alpha.4
  • npm babel-traverse

    Affected
    every version
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-45133: 0.53% estimated exploitation activity in the next 30 days; percentile 44.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Using Babel to compile code that was specifically crafted by an attacker can lead to arbitrary code execution during compilation, when using plugins that rely on the `path.evaluate()`or `path.evaluateTruthy()` internal Babel methods. Known affected plugins are: - `@babel/plugin-transform-runtime` - `@babel/preset-env` when using its `useBuiltIns` option - Any "polyfill provider" plugin that depends on `@babel/helper-define-polyfill-provider`, such as `babel-plugin-polyfill-corejs3`, `babel-plugin-polyfill-corejs2`, `babel-plugin-polyfill-es-shims`, `babel-plugin-polyfill-regenerator` No other plugins under the `@babel/` namespace are impacted, but third-party plugins might be. Users that only compile trusted code are not impacted.

Patches The vulnerability has been fixed in `@babel/traverse@7.23.2`. Babel 6 does not receive security fixes anymore (see Babel's security…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-67hx-6x53-jw92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-45133

Advisory: Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code
IDs: CVE-2023-45133, GHSA-67hx-6x53-jw92
Record: https://patchnext.com/advisories/cve-2023-45133 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @babel/traverse 8.0.0-alpha.4, 7.23.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @babel/traverse: affected < 7.23.2; >= 8.0.0-alpha.0, < 8.0.0-alpha.4; fixed in 7.23.2, 8.0.0-alpha.4
- npm babel-traverse: affected every version

## Suggested inspection (read-only)
- `npm ls @babel/traverse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls babel-traverse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @babel/traverse, babel-traverse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-67hx-6x53-jw92 (OSV record GHSA-67hx-6x53-jw92 lists affected ranges: npm @babel/traverse >=0 =8.0.0-alpha.0 =0)

Commands are suggestions: review each one before running it.

Loading voting…