Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper
CVE-2023-44981GHSA-7286-pgfv-vxvh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.zookeeper:zookeeper 3.9.1, 3.8.3, 3.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.zookeeper:zookeeper
- Affected
- < 3.7.2>= 3.8.0, < 3.8.3>= 3.9.0, < 3.9.1
- Fixed in
- 3.7.2, 3.9.1, 3.8.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7286-pgfv-vxvh lists affected ranges: Maven org.apache.zookeeper:zookeeper >=0 =3.8.0 =3.9.0 <3.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-44981: 2.22% estimated exploitation activity in the next 30 days; percentile 82.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper. If SASL Quorum Peer authentication is enabled in ZooKeeper (quorum.auth.enableSasl=true), the authorization is done by verifying that the instance part in SASL authentication ID is listed in zoo.cfg server list. The instance part in SASL auth ID is optional and if it's missing, like 'eve@EXAMPLE.COM', the authorization check will be skipped. As a result an arbitrary endpoint could join the cluster and begin propagating counterfeit changes to the leader, essentially giving it complete read-write access to the data tree. Quorum Peer authentication is not enabled by default. Users are recommended to upgrade to version 3.9.1, 3.8.3, 3.7.2, which fixes the issue. Alternately ensure the ensemble election/quorum communication is protected by a firewall as this will mitigate the issue. See the documentation for more details on correct cluster administration.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7286-pgfv-vxvh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-44981 Advisory: Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper IDs: CVE-2023-44981, GHSA-7286-pgfv-vxvh Record: https://patchnext.com/advisories/cve-2023-44981 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.zookeeper:zookeeper 3.9.1, 3.8.3, 3.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.zookeeper:zookeeper: affected < 3.7.2; >= 3.8.0, < 3.8.3; >= 3.9.0, < 3.9.1; fixed in 3.7.2, 3.9.1, 3.8.3 ## Suggested inspection (read-only) - Maven org.apache.zookeeper:zookeeper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.zookeeper:zookeeper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7286-pgfv-vxvh (GitHub-reviewed advisory GHSA-7286-pgfv-vxvh lists affected ranges: Maven org.apache.zookeeper:zookeeper >=0 =3.8.0 =3.9.0 <3.9.1) Commands are suggestions: review each one before running it.
Loading voting…