Skip to content

← Actionable
Medium, CVSS 5.5

Google Sheets data source plugin for Grafana information disclosure vulnerability

CVE-2023-4457GHSA-37x5-qpm8-53rq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/grafana/google-sheets-datasource 1.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-4457: 0.46% estimated exploitation activity in the next 30 days; percentile 40.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Grafana is an open-source platform for monitoring and observability. The Google Sheets data source plugin for Grafana, versions 0.9.0 to 1.2.2 are vulnerable to an information disclosure vulnerability. The plugin did not properly sanitize error messages, making it potentially expose the Google Sheet API-key that is configured for the data source. This vulnerability was fixed in version 1.2.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-37x5-qpm8-53rq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-4457

Advisory: Google Sheets data source plugin for Grafana information disclosure vulnerability
IDs: CVE-2023-4457, GHSA-37x5-qpm8-53rq
Record: https://patchnext.com/advisories/cve-2023-4457 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/grafana/google-sheets-datasource 1.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/grafana/google-sheets-datasource: affected >= 0.9.0, < 1.2.2; fixed in 1.2.2

## Suggested inspection (read-only)
- Go github.com/grafana/google-sheets-datasource: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/grafana/google-sheets-datasource.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-37x5-qpm8-53rq (GitHub-reviewed advisory GHSA-37x5-qpm8-53rq lists affected ranges: Go github.com/grafana/google-sheets-datasource >=0.9.0 <1.2.2)

Commands are suggestions: review each one before running it.

Loading voting…