Wallabag user can delete own API client unintentionally
CVE-2023-4455GHSA-gjvc-55fw-v6vq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wallabag/wallabag 2.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wallabag/wallabag
- Affected
- >= 2.0.0-alpha.1, <= 2.6.2
- Fixed in
- 2.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gjvc-55fw-v6vq lists affected ranges: Packagist wallabag/wallabag >=2.0.0-alpha.1 <=2.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-4455: 0.32% estimated exploitation activity in the next 30 days; percentile 25.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily delete API key via /developer/client/delete/{id} This vulnerability has a CVSSv3.1 score of 6.5. You should immediately patch your instance to version 2.6.3 or higher if you have more than one user and/or having open registration. Resolution This action is now doable only via POST method, which ensures that we can't do it via a 3rd-party website. Credits We would like to thank @tht1997 for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/5ab1b206-5fe8-4737-b275-d705e76f193a/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gjvc-55fw-v6vq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-4455 Advisory: Wallabag user can delete own API client unintentionally IDs: CVE-2023-4455, GHSA-gjvc-55fw-v6vq Record: https://patchnext.com/advisories/cve-2023-4455 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wallabag/wallabag 2.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wallabag/wallabag: affected >= 2.0.0-alpha.1, <= 2.6.2; fixed in 2.6.3 ## Suggested inspection (read-only) - Packagist wallabag/wallabag: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wallabag/wallabag. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gjvc-55fw-v6vq (GitHub-reviewed advisory GHSA-gjvc-55fw-v6vq lists affected ranges: Packagist wallabag/wallabag >=2.0.0-alpha.1 <=2.6.2) Commands are suggestions: review each one before running it.
Loading voting…