Skip to content

← Actionable
Medium, CVSS 5.3

View permissions are bypassed for paginated lists of ORM data

CVE-2023-44401GHSA-jgph-w8rh-xf5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/graphql 5.1.3, 4.3.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-44401: 0.42% estimated exploitation activity in the next 30 days; percentile 36.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact canView permission checks are bypassed for ORM data in paginated GraphQL query results where the total number of records is greater than the number of records per page. Note that this also affects GraphQL queries which have a limit applied, even if the query isn’t paginated per se. This has been fixed by ensuring no new records are pulled in from the database after performing canView permission checks for each page of results. This may result in some pages in your query results having less than the maximum number of records per page even when there are more pages of results. This behaviour is consistent with how pagination works in other areas of Silverstripe CMS, such as in GridField, and is a result of having to perform permission checks in PHP rather than in the database directly. You can choose to disable these permission checks by disabling the CanViewPermission plugin following the instructions in overriding default plugins. Note that this vulnerability does not affect…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jgph-w8rh-xf5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-44401

Advisory: View permissions are bypassed for paginated lists of ORM data
IDs: CVE-2023-44401, GHSA-jgph-w8rh-xf5p
Record: https://patchnext.com/advisories/cve-2023-44401 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/graphql 5.1.3, 4.3.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/graphql: affected >= 4.0.0, < 4.3.7; >= 5.0.0, < 5.1.3; fixed in 5.1.3, 4.3.7

## Suggested inspection (read-only)
- Packagist silverstripe/graphql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jgph-w8rh-xf5p (GitHub-reviewed advisory GHSA-jgph-w8rh-xf5p lists affected ranges: Packagist silverstripe/graphql >=4.0.0 =5.0.0 <5.1.3)

Commands are suggestions: review each one before running it.

Loading voting…