Skip to content

← Actionable
Medium, CVSS 5.4

October CMS stored XSS by authenticated backend user with improper configuration

CVE-2023-44383GHSA-rvx8-p3xp-fj3p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 3.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-44383: 0.41% estimated exploitation activity in the next 30 days; percentile 35.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user with access to the media manager that stores SVG files could create a stored XSS attack against themselves and any other user with access to the media manager when SVG files are supported. SVG files are supported by default in v3 for convenience; however, this has resulted in multiple mistaken vulnerability reports from security researchers. As per the documentation, if a backend user is not trusted, the advice is to remove the svg extension from the list of supported file types. Patches The issue has been patched in v3.5.2 by including an SVG sanister. It is enabled by default for new installations but must be enabled for existing sites in the config/media.php file. Workarounds If you cannot upgrade for this patch, follow the pervious advice and remove svg from the supported file types. References - https://github.com/octobercms/october/blob/3.x/config/media.php Credits to: - Faris Krivic - Okan Kurtulus - Aldin Visnjic - Bug Shankar For more information If you have…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rvx8-p3xp-fj3p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-44383

Advisory: October CMS stored XSS by authenticated backend user with improper configuration
IDs: CVE-2023-44383, GHSA-rvx8-p3xp-fj3p
Record: https://patchnext.com/advisories/cve-2023-44383 (revision 1, source checked 26 Oct 2026, 14:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 3.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected >= 3.0.0, < 3.5.2; fixed in 3.5.2

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rvx8-p3xp-fj3p (GitHub-reviewed advisory GHSA-rvx8-p3xp-fj3p lists affected ranges: Packagist october/system >=3.0.0 <3.5.2)

Commands are suggestions: review each one before running it.

Loading voting…