gnark unsoundness in variable comparison / non-unique binary decomposition
CVE-2023-44378GHSA-498w-5j49-vqjg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/consensys/gnark 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.9.0
- Fixed in
- 0.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-498w-5j49-vqjg lists affected ranges: Go github.com/consensys/gnark >=0 <0.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-44378: 0.23% estimated exploitation activity in the next 30 days; percentile 14.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact For some in-circuit values, it is possible to construct two valid decomposition to bits. In addition to the canonical decomposition of a, for small values there exists a second decomposition for a+r (where r is the modulus the values are being reduced by). The second decomposition was possible due to overflowing the field where the values are defined. Internally, the comparison methods frontend.API.Cmp and frontend.API.IsLess used binary decomposition and checked the bitwise differences. This allows a malicious prover to construct a valid proof for a statement a < b even if a b. The issue impacts all users using API.Cmp or API.IsLess methods. Additionally, it impacts the users using bits.ToBinary or API.ToBinary methods if full-width decomposition is requested (the default behaviour if no options are given). The issues does not impact comparison methods in field emulation (package std/math/emulated) and dedicated comparison package (std/math/cmp). Patches Fix has been…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-498w-5j49-vqjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-44378 Advisory: gnark unsoundness in variable comparison / non-unique binary decomposition IDs: CVE-2023-44378, GHSA-498w-5j49-vqjg Record: https://patchnext.com/advisories/cve-2023-44378 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/consensys/gnark 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/consensys/gnark: affected < 0.9.0; fixed in 0.9.0 ## Suggested inspection (read-only) - Go github.com/consensys/gnark: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/consensys/gnark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-498w-5j49-vqjg (GitHub-reviewed advisory GHSA-498w-5j49-vqjg lists affected ranges: Go github.com/consensys/gnark >=0 <0.9.0) Commands are suggestions: review each one before running it.
Loading voting…