PostCSS line return parsing error
CVE-2023-44270GHSA-7fh5-64p2-3v2j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (postcss 8.4.31), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm postcss
- Affected
- < 8.4.31
- Fixed in
- 8.4.31
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7fh5-64p2-3v2j lists affected ranges: npm postcss >=0 <8.4.31 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7fh5-64p2-3v2j lists affected ranges: npm postcss >=0 <8.4.31
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2023-44270: 0.97% estimated exploitation activity in the next 30 days; percentile 62.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in PostCSS before 8.4.31. It affects linters using PostCSS to parse external Cascading Style Sheets (CSS). There may be \r discrepancies, as demonstrated by @font-face{ font:(\r/);} in a rule. This vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being originally included in a comment.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7fh5-64p2-3v2j
- Revision 1 · created ·
Published from osv record GHSA-7fh5-64p2-3v2j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-44270 Advisory: PostCSS line return parsing error IDs: CVE-2023-44270, GHSA-7fh5-64p2-3v2j Record: https://patchnext.com/advisories/cve-2023-44270 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: postcss 8.4.31. A vendor fix does not mean a deployment is fixed. ## Affected components - npm postcss: affected < 8.4.31; fixed in 8.4.31 ## Suggested inspection (read-only) - `npm ls postcss --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on postcss. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7fh5-64p2-3v2j (OSV record GHSA-7fh5-64p2-3v2j lists affected ranges: npm postcss >=0 <8.4.31 (fixed)) - Verified: https://github.com/advisories/GHSA-7fh5-64p2-3v2j (GitHub-reviewed advisory GHSA-7fh5-64p2-3v2j lists affected ranges: npm postcss >=0 <8.4.31) Commands are suggestions: review each one before running it.
Loading voting…