Skip to content

← Actionable
High, CVSS 7.4amended

Cookie HTTP header isn't stripped on cross-origin redirects

CVE-2023-43804GHSA-v845-jxx5-vc9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (urllib3 2.0.6, 1.26.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI urllib3

    Affected
    >= 2.0.0, < 2.0.6< 1.26.17
    Fixed in
    1.26.17, 2.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-43804: 1.36% estimated exploitation activity in the next 30 days; percentile 71.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

urllib3 doesn't treat the Cookie HTTP header special or provide any helpers for managing cookies over HTTP, that is the responsibility of the user. However, it is possible for a user to specify a Cookie header and unknowingly leak information via HTTP redirects to a different origin if that user doesn't disable redirects explicitly. Users must handle redirects themselves instead of relying on urllib3's automatic redirects to achieve safe processing of the Cookie header, thus we decided to strip the header by default in order to further protect users who aren't using the correct approach. Affected usages We believe the number of usages affected by this advisory is low. It requires all of the following to be true to be exploited: Using an affected version of urllib3 (patched in v1.26.17 and v2.0.6) Using the Cookie header on requests, which is mostly typical for impersonating a browser. Not disabling HTTP redirects Either not using HTTPS or for the origin server to redirect to a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v845-jxx5-vc9f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v845-jxx5-vc9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-43804

Advisory: `Cookie` HTTP header isn't stripped on cross-origin redirects
IDs: CVE-2023-43804, GHSA-v845-jxx5-vc9f
Record: https://patchnext.com/advisories/cve-2023-43804 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: urllib3 2.0.6, 1.26.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI urllib3: affected >= 2.0.0, < 2.0.6; < 1.26.17; fixed in 1.26.17, 2.0.6

## Suggested inspection (read-only)
- `python -m pip show urllib3`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on urllib3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v845-jxx5-vc9f (OSV record GHSA-v845-jxx5-vc9f lists affected ranges: PyPI urllib3 >=2.0.0 =0 <1.26.17 (fixed))
- Verified: https://github.com/advisories/GHSA-v845-jxx5-vc9f (GitHub-reviewed advisory GHSA-v845-jxx5-vc9f lists affected ranges: PyPI urllib3 >=2.0.0 =0 <1.26.17)

Commands are suggestions: review each one before running it.

Loading voting…