Skip to content

← Actionable
High, CVSS 8.6

WPS Server Side Request Forgery vulnerability

CVE-2023-43795GHSA-5pr3-m5hm-9956

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.extension:gs-wps-core 2.23.2, 2.22.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2023-43795: 69.03% estimated exploitation activity in the next 30 days; percentile 99.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. Details This vulnerability requires: The WPS extension to be installed The WPS security setting "Disable complex inputs" to be unselected Security URL checks to be disabled Impact This vulnerability presents the opportunity for Server Side Request Forgery. Mitigation The ability to reference an external URL location is defined by the WPS standard Execute operation. This operations is defined by an Industry and International standard and cannot be redefined by the GeoServer application in isolation. To disable complex remote inputs on GeoServer 2.20.5 and GeoServer 2.21.0: 1. Navigate to Security WPS Security page 2. Locate Complex Inputs heading 3. Select the check box for Disable loading complex inputs from remote references Resolution To allow processing of complex inputs safely in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5pr3-m5hm-9956

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-43795

Advisory: WPS Server Side Request Forgery vulnerability
IDs: CVE-2023-43795, GHSA-5pr3-m5hm-9956
Record: https://patchnext.com/advisories/cve-2023-43795 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver.extension:gs-wps-core 2.23.2, 2.22.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver.extension:gs-wps-core: affected < 2.22.5; >= 2.23.0, < 2.23.2; fixed in 2.22.5, 2.23.2

## Suggested inspection (read-only)
- Maven org.geoserver.extension:gs-wps-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver.extension:gs-wps-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5pr3-m5hm-9956 (GitHub-reviewed advisory GHSA-5pr3-m5hm-9956 lists affected ranges: Maven org.geoserver.extension:gs-wps-core >=0 =2.23.0 <2.23.2)

Commands are suggestions: review each one before running it.

Loading voting…