Django Denial-of-service in django.utils.text.Truncator
CVE-2023-43665GHSA-h8gc-pgj2-vjm3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (django 4.2.6, 4.1.12, 3.2.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI django
- Affected
- >= 3.2a1, < 3.2.22>= 4.1a1, < 4.1.12>= 4.2a1, < 4.2.6
- Fixed in
- 3.2.22, 4.1.12, 4.2.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h8gc-pgj2-vjm3 lists affected ranges: PyPI django >=3.2a1 =4.1a1 =4.2a1 <4.2.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8gc-pgj2-vjm3 lists affected ranges: PyPI django >=3.2a1 =4.1a1 =4.2a1 <4.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-43665: 1.46% estimated exploitation activity in the next 30 days; percentile 73.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Django 3.2 before 3.2.22, 4.1 before 4.1.12, and 4.2 before 4.2.6, the django.utils.text.Truncator chars() and words() methods (when used with html=True) are subject to a potential DoS (denial of service) attack via certain inputs with very long, potentially malformed HTML text. The chars() and words() methods are used to implement the truncatecharshtml and truncatewordshtml template filters, which are thus also vulnerable. NOTE: this issue exists because of an incomplete fix for CVE-2019-14232.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h8gc-pgj2-vjm3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h8gc-pgj2-vjm3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-43665 Advisory: Django Denial-of-service in django.utils.text.Truncator IDs: CVE-2023-43665, GHSA-h8gc-pgj2-vjm3 Record: https://patchnext.com/advisories/cve-2023-43665 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: django 4.2.6, 4.1.12, 3.2.22. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI django: affected >= 3.2a1, < 3.2.22; >= 4.1a1, < 4.1.12; >= 4.2a1, < 4.2.6; fixed in 3.2.22, 4.1.12, 4.2.6 ## Suggested inspection (read-only) - `python -m pip show django`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on django. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h8gc-pgj2-vjm3 (OSV record GHSA-h8gc-pgj2-vjm3 lists affected ranges: PyPI django >=3.2a1 =4.1a1 =4.2a1 <4.2.6 (fixed)) - Verified: https://github.com/advisories/GHSA-h8gc-pgj2-vjm3 (GitHub-reviewed advisory GHSA-h8gc-pgj2-vjm3 lists affected ranges: PyPI django >=3.2a1 =4.1a1 =4.2a1 <4.2.6) Commands are suggestions: review each one before running it.
Loading voting…