Skip to content

← Actionable
Critical, CVSS 9.8amended

TorchServe Server-Side Request Forgery vulnerability

CVE-2023-43654GHSA-8fxr-qfr9-p34w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (torchserve 0.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI torchserve

    Affected
    >= 0.1.0, < 0.8.2
    Fixed in
    0.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-43654: 42.49% estimated exploitation activity in the next 30 days; percentile 98.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Remote Server-Side Request Forgery (SSRF) Issue: TorchServe default configuration lacks proper input validation, enabling third parties to invoke remote HTTP download requests and write files to the disk. This issue could be taken advantage of to compromise the integrity of the system and sensitive data. This issue is present in versions 0.1.0 to 0.8.1. Mitigation: The user is able to load the model of their choice from any URL that they would like to use. The user of TorchServe is responsible for configuring both the allowedurls and specifying the model URL to be used. A pull request to warn the user when the default value for allowedurls is used has been merged - https://github.com/pytorch/serve/pull/2534. TorchServe release 0.8.2 includes this change. Patches TorchServe release 0.8.2 includes fixes to address the previously listed issue: https://github.com/pytorch/serve/releases/tag/v0.8.2 Tags for upgraded DLC release User can use the following new image tags to pull DLCs…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8fxr-qfr9-p34w

  2. Revision 1 · created ·

    Published from osv record GHSA-8fxr-qfr9-p34w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-43654

Advisory: TorchServe Server-Side Request Forgery vulnerability
IDs: CVE-2023-43654, GHSA-8fxr-qfr9-p34w
Record: https://patchnext.com/advisories/cve-2023-43654 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: torchserve 0.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI torchserve: affected >= 0.1.0, < 0.8.2; fixed in 0.8.2

## Suggested inspection (read-only)
- `python -m pip show torchserve`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on torchserve.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8fxr-qfr9-p34w (OSV record GHSA-8fxr-qfr9-p34w lists affected ranges: PyPI torchserve >=0.1.0 <0.8.2 (fixed))
- Verified: https://github.com/advisories/GHSA-8fxr-qfr9-p34w (GitHub-reviewed advisory GHSA-8fxr-qfr9-p34w lists affected ranges: PyPI torchserve >=0.1.0 <0.8.2)

Commands are suggestions: review each one before running it.

Loading voting…