Skip to content

← Actionable
High, CVSS 7.5amended

Chaijs/get-func-name vulnerable to ReDoS

CVE-2023-43646GHSA-4q6p-r6v2-jvc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (get-func-name 2.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-43646: 1.38% estimated exploitation activity in the next 30 days; percentile 72.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The current regex implementation for parsing values in the module is susceptible to excessive backtracking, leading to potential DoS attacks. The regex implementation in question is as follows: This vulnerability can be exploited when there is an imbalance in parentheses, which results in excessive backtracking and subsequently increases the CPU load and processing time significantly. This vulnerability can be triggered using the following input: Here is a simple PoC code to demonstrate the issue:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4q6p-r6v2-jvc5

  2. Revision 1 · created ·

    Published from osv record GHSA-4q6p-r6v2-jvc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-43646

Advisory: Chaijs/get-func-name vulnerable to ReDoS
IDs: CVE-2023-43646, GHSA-4q6p-r6v2-jvc5
Record: https://patchnext.com/advisories/cve-2023-43646 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: get-func-name 2.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm get-func-name: affected < 2.0.1; fixed in 2.0.1

## Suggested inspection (read-only)
- `npm ls get-func-name --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on get-func-name.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4q6p-r6v2-jvc5 (OSV record GHSA-4q6p-r6v2-jvc5 lists affected ranges: npm get-func-name >=0 <2.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4q6p-r6v2-jvc5 (GitHub-reviewed advisory GHSA-4q6p-r6v2-jvc5 lists affected ranges: npm get-func-name >=0 <2.0.1)

Commands are suggestions: review each one before running it.

Loading voting…