Skip to content

← Actionable
Medium, CVSS 6.1

mXSS in AntiSamy

CVE-2023-43643GHSA-pcf2-gh6g-h5r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.owasp.antisamy:antisamy 1.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-43643: 0.54% estimated exploitation activity in the next 30 days; percentile 45.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the preserveComments directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patches Patched in AntiSamy 1.7.4 and later. See important remediation details in the reference given below. Workarounds If you cannot upgrade to a fixed version of the library, the following mitigation can be applied until you can upgrade: Manually edit your AntiSamy policy file (e.g., antisamy.xml) by deleting the preserveComments directive or setting its value to false, if present. Also it would be useful to make AntiSamy remove the noscript tag by adding this in your tag definitions under the <tagrules node (or deleting it entirely if present): As the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pcf2-gh6g-h5r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-43643

Advisory: mXSS in AntiSamy
IDs: CVE-2023-43643, GHSA-pcf2-gh6g-h5r2
Record: https://patchnext.com/advisories/cve-2023-43643 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.owasp.antisamy:antisamy 1.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.owasp.antisamy:antisamy: affected <= 1.7.3; fixed in 1.7.4

## Suggested inspection (read-only)
- Maven org.owasp.antisamy:antisamy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.owasp.antisamy:antisamy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pcf2-gh6g-h5r2 (GitHub-reviewed advisory GHSA-pcf2-gh6g-h5r2 lists affected ranges: Maven org.owasp.antisamy:antisamy >=0 <=1.7.3)

Commands are suggestions: review each one before running it.

Loading voting…