snappy-java's missing upper bound check on chunk length can lead to Denial of Service (DoS) impact
CVE-2023-43642GHSA-55g7-9cwv-5qfv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xerial.snappy:snappy-java 1.1.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xerial.snappy:snappy-java
- Affected
- <= 1.1.10.3
- Fixed in
- 1.1.10.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-55g7-9cwv-5qfv lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <=1.1.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-43642: 1.21% estimated exploitation activity in the next 30 days; percentile 68.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary snappy-java is a data compression library in Java. Its SnappyInputStream was found to be vulnerable to Denial of Service (DoS) attacks when decompressing data with a too-large chunk size. Due to missing upper bound check on chunk length, an unrecoverable fatal error can occur. Scope All versions of snappy-java including the latest released version 1.1.10.3. A fix is applied in 1.1.10.4 Details While performing mitigation efforts related to CVE-2023-34455 in Confluent products, our Application Security team closely analyzed the fix that was accepted and merged into snappy-java version 1.1.10.1 in this commit. The check on line 421 only attempts to check if chunkSize is not a negative value. We believe that this is an inadequate fix as it misses an upper-bounds check for overly positive values such as 0x7FFFFFFF (or (2,147,483,647 in decimal) before actually attempting to allocate the provided unverified number of bytes via the “chunkSize” variable. This missing upper-bounds…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-55g7-9cwv-5qfv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-43642 Advisory: snappy-java's missing upper bound check on chunk length can lead to Denial of Service (DoS) impact IDs: CVE-2023-43642, GHSA-55g7-9cwv-5qfv Record: https://patchnext.com/advisories/cve-2023-43642 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xerial.snappy:snappy-java 1.1.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xerial.snappy:snappy-java: affected <= 1.1.10.3; fixed in 1.1.10.4 ## Suggested inspection (read-only) - Maven org.xerial.snappy:snappy-java: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xerial.snappy:snappy-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-55g7-9cwv-5qfv (GitHub-reviewed advisory GHSA-55g7-9cwv-5qfv lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <=1.1.10.3) Commands are suggestions: review each one before running it.
Loading voting…