pimcore/admin-ui-classic-bundle Cross-site Scripting vulnerability in Translations
CVE-2023-42817GHSA-m988-7375-7g2c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/admin-ui-classic-bundle 1.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/admin-ui-classic-bundle
- Affected
- < 1.1.2
- Fixed in
- 1.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m988-7375-7g2c lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-42817: 0.38% estimated exploitation activity in the next 30 days; percentile 32.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The translation value with text including “%s” (from “%suggest%) is parsed by sprintf() even though it’s supposed to be output literally to the user. The translations may be accessible by a user with comparatively lower overall access (as the translation permission cannot be scoped to certain “modules”) and a skilled attacker might be able to exploit the parsing of the translation string in the dialog box. Patches https://github.com/pimcore/admin-ui-classic-bundle/commit/abd7739298f974319e3cac3fd4fcd7f995b63e4c.patch Workarounds Update to version 1.1.2 or apply this patches manually https://github.com/pimcore/admin-ui-classic-bundle/commit/abd7739298f974319e3cac3fd4fcd7f995b63e4c.patch
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m988-7375-7g2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42817 Advisory: pimcore/admin-ui-classic-bundle Cross-site Scripting vulnerability in Translations IDs: CVE-2023-42817, GHSA-m988-7375-7g2c Record: https://patchnext.com/advisories/cve-2023-42817 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/admin-ui-classic-bundle 1.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/admin-ui-classic-bundle: affected < 1.1.2; fixed in 1.1.2 ## Suggested inspection (read-only) - Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/admin-ui-classic-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m988-7375-7g2c (GitHub-reviewed advisory GHSA-m988-7375-7g2c lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.1.2) Commands are suggestions: review each one before running it.
Loading voting…