Skip to content

← Actionable
Medium, CVSS 6.5amended

Apache Airflow vulnerable to sensitive information exposure when users list warnings for all DAGs

CVE-2023-42780GHSA-cgx2-rrmr-jx43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-42780: 1.44% estimated exploitation activity in the next 30 days; percentile 73.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dagids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cgx2-rrmr-jx43

  2. Revision 1 · created ·

    Published from osv record GHSA-cgx2-rrmr-jx43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-42780

Advisory: Apache Airflow vulnerable to sensitive information exposure when users list warnings for all DAGs
IDs: CVE-2023-42780, GHSA-cgx2-rrmr-jx43
Record: https://patchnext.com/advisories/cve-2023-42780 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 2.7.2; fixed in 2.7.2

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cgx2-rrmr-jx43 (OSV record GHSA-cgx2-rrmr-jx43 lists affected ranges: PyPI apache-airflow >=0 <2.7.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cgx2-rrmr-jx43 (GitHub-reviewed advisory GHSA-cgx2-rrmr-jx43 lists affected ranges: PyPI apache-airflow >=0 <2.7.2)

Commands are suggestions: review each one before running it.

Loading voting…