Apache Superset has Incorrect Default Permissions
CVE-2023-42501GHSA-vv65-fjfj-4736
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 2.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- < 2.1.2
- Fixed in
- 2.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vv65-fjfj-4736 lists affected ranges: PyPI apache-superset >=0 <2.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vv65-fjfj-4736 lists affected ranges: PyPI apache-superset >=0 <2.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-42501: 0.86% estimated exploitation activity in the next 30 days; percentile 58.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run superset init to reconstruct the Gamma role or remove canread permission from the mentioned resources.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vv65-fjfj-4736
- Revision 1 · created ·
Published from osv record GHSA-vv65-fjfj-4736
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42501 Advisory: Apache Superset has Incorrect Default Permissions IDs: CVE-2023-42501, GHSA-vv65-fjfj-4736 Record: https://patchnext.com/advisories/cve-2023-42501 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 2.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected < 2.1.2; fixed in 2.1.2 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vv65-fjfj-4736 (OSV record GHSA-vv65-fjfj-4736 lists affected ranges: PyPI apache-superset >=0 <2.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-vv65-fjfj-4736 (GitHub-reviewed advisory GHSA-vv65-fjfj-4736 lists affected ranges: PyPI apache-superset >=0 <2.1.2) Commands are suggestions: review each one before running it.
Loading voting…