Zope vulnerable to Stored Cross Site Scripting with SVG images
CVE-2023-42458GHSA-wm8q-9975-xh5v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zope 5.8.5, 4.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zope
- Affected
- <= 4.8.9>= 5.8.0, <= 5.8.4
- Fixed in
- 4.8.10, 5.8.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wm8q-9975-xh5v lists affected ranges: PyPI zope >=0 =5.8.0 <5.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wm8q-9975-xh5v lists affected ranges: PyPI zope >=0 =5.8.0 <=5.8.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2023-42458: 0.71% estimated exploitation activity in the next 30 days; percentile 53.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. All versions of Zope are impacted on sites that allow untrusted users to upload images. Patches Patches will be released in Zope 4.8.10 and 5.8.5. Workarounds Make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default only the Manager has this permission.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wm8q-9975-xh5v
- Revision 1 · created ·
Published from osv record GHSA-wm8q-9975-xh5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42458 Advisory: Zope vulnerable to Stored Cross Site Scripting with SVG images IDs: CVE-2023-42458, GHSA-wm8q-9975-xh5v Record: https://patchnext.com/advisories/cve-2023-42458 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zope 5.8.5, 4.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zope: affected <= 4.8.9; >= 5.8.0, <= 5.8.4; fixed in 4.8.10, 5.8.5 ## Suggested inspection (read-only) - `python -m pip show zope`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zope. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wm8q-9975-xh5v (OSV record GHSA-wm8q-9975-xh5v lists affected ranges: PyPI zope >=0 =5.8.0 <5.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-wm8q-9975-xh5v (GitHub-reviewed advisory GHSA-wm8q-9975-xh5v lists affected ranges: PyPI zope >=0 =5.8.0 <=5.8.4) Commands are suggestions: review each one before running it.
Loading voting…