Skip to content

← Actionable
Critical, CVSS 10.0

SQLpage vulnerable to public exposure of database credentials

CVE-2023-42454GHSA-v5wf-jg37-r9m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlpage 0.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io sqlpage

    Affected
    < 0.11.1
    Fixed in
    0.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2023-42454: 0.74% estimated exploitation activity in the next 30 days; percentile 54.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If - you are using a SQLPage version older than v0.11.1 - your SQLPage instance is exposed publicly - the database connection string is specified in the sqlpage/sqlpage.json configuration file (not in an environment variable) - the webroot is the current working directory (the default) - your database is exposed publicly then an attacker could retrieve the database connection information from SQLPage and use it to connect to your database directly. Patches Upgrade to v0.11.1 as soon as possible. Workarounds If you cannot upgrade immediately: - Using an environment variable instead of the configuration file to specify the database connection string prevents exposing it on vulnerable versions. - Using a different web root (that is not a parent of the SQLPage configuration directory) fixes the issue. - And in any case, you should generally avoid exposing your database publicly References https://github.com/lovasoa/SQLpage/issues/89

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v5wf-jg37-r9m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-42454

Advisory: SQLpage vulnerable to public exposure of database credentials
IDs: CVE-2023-42454, GHSA-v5wf-jg37-r9m5
Record: https://patchnext.com/advisories/cve-2023-42454 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sqlpage 0.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io sqlpage: affected < 0.11.1; fixed in 0.11.1

## Suggested inspection (read-only)
- crates.io sqlpage: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sqlpage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v5wf-jg37-r9m5 (GitHub-reviewed advisory GHSA-v5wf-jg37-r9m5 lists affected ranges: crates.io sqlpage >=0 <0.11.1)

Commands are suggestions: review each one before running it.

Loading voting…