matrix-synapse vulnerable to improper validation of receipts allows forged read receipts
CVE-2023-42453GHSA-7565-cq32-vx2x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.93.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- >= 0.34.0, < 1.93.0
- Fixed in
- 1.93.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7565-cq32-vx2x lists affected ranges: PyPI matrix-synapse >=0.34.0 <1.93.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7565-cq32-vx2x lists affected ranges: PyPI matrix-synapse >=0.34.0 <1.93.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-42453: 0.78% estimated exploitation activity in the next 30 days; percentile 55.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users were able to forge read receipts for any event (if they knew the room ID and event ID). Note that the users were not able to view the events, but simply mark it as read. This could be confusing as clients will show the event as read by the user, even if they are not in the room. Patches https://github.com/matrix-org/synapse/pull/16327 Workarounds There is no workaround.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7565-cq32-vx2x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7565-cq32-vx2x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42453 Advisory: matrix-synapse vulnerable to improper validation of receipts allows forged read receipts IDs: CVE-2023-42453, GHSA-7565-cq32-vx2x Record: https://patchnext.com/advisories/cve-2023-42453 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.93.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected >= 0.34.0, < 1.93.0; fixed in 1.93.0 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7565-cq32-vx2x (OSV record GHSA-7565-cq32-vx2x lists affected ranges: PyPI matrix-synapse >=0.34.0 <1.93.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7565-cq32-vx2x (GitHub-reviewed advisory GHSA-7565-cq32-vx2x lists affected ranges: PyPI matrix-synapse >=0.34.0 <1.93.0) Commands are suggestions: review each one before running it.
Loading voting…