Vyper vulnerable to memory corruption in certain builtins utilizing msize
CVE-2023-42443GHSA-c647-pxm2-c52w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vyper
- Affected
- >= 0.3.4, <= 0.3.9
- Fixed in
- 0.3.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c647-pxm2-c52w lists affected ranges: PyPI vyper >=0.3.4 <0.3.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c647-pxm2-c52w lists affected ranges: PyPI vyper >=0.3.4 <=0.3.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-42443: 0.83% estimated exploitation activity in the next 30 days; percentile 57.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In certain conditions, the memory used by the builtins rawcall, createfromblueprint and createcopyof can be corrupted. - For rawcall, the argument buffer of the call can be corrupted, leading to incorrect calldata in the sub-context. - For createfromblueprint and createcopyof, the buffer for the to-be-deployed bytecode can be corrupted, leading to deploying incorrect bytecode. Below are the conditions that must be fulfilled for the corruption to happen for each builtin: rawcall - memory is not fully initialized, ex. all parameters to an external function live in calldata and - The data argument of the builtin is msg.data. and - The to, value or gas passed to the builtin is some complex expression that results in writing to uninitialized memory (e.g. calling an internal function) createcopyof - memory is not fully initialized, ex. all parameters to an external function live in calldata and - The value or salt passed to the builtin is some complex expression that results in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c647-pxm2-c52w
- Revision 1 · created ·
Published from osv record GHSA-c647-pxm2-c52w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42443 Advisory: Vyper vulnerable to memory corruption in certain builtins utilizing `msize` IDs: CVE-2023-42443, GHSA-c647-pxm2-c52w Record: https://patchnext.com/advisories/cve-2023-42443 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vyper: affected >= 0.3.4, <= 0.3.9; fixed in 0.3.10 ## Suggested inspection (read-only) - `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c647-pxm2-c52w (OSV record GHSA-c647-pxm2-c52w lists affected ranges: PyPI vyper >=0.3.4 <0.3.10 (fixed)) - Verified: https://github.com/advisories/GHSA-c647-pxm2-c52w (GitHub-reviewed advisory GHSA-c647-pxm2-c52w lists affected ranges: PyPI vyper >=0.3.4 <=0.3.9) Commands are suggestions: review each one before running it.
Loading voting…