GeoNode vulnerable to SSRF Bypass to return internal host data
CVE-2023-42439GHSA-pxg5-h34r-7q8p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (geonode 4.1.3.post1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI geonode
- Affected
- >= 3.2.0, <= 4.1.2
- Fixed in
- 4.1.3.post1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pxg5-h34r-7q8p lists affected ranges: PyPI geonode >=3.2.0 <4.1.3.post1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pxg5-h34r-7q8p lists affected ranges: PyPI geonode >=3.2.0 <=4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-42439: 0.96% estimated exploitation activity in the next 30 days; percentile 61.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A SSRF vulnerability exists, bypassing existing controls on the software. This can allow a user to request internal services for a full read SSRF, returning any data from the internal network. the application is using a whitelist, but the whitelist can be bypassed with @ and encoded value of @ (%40) GET /proxy/?url=http://development.demo.geonode.org%40geoserver:8080/geoserver/web This will trick the application that the first host is a whitelisted address, but the browser will use @ or %40 as a credential to the host geoserver on port 8080, this will return the data to that host on the response.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pxg5-h34r-7q8p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pxg5-h34r-7q8p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42439 Advisory: GeoNode vulnerable to SSRF Bypass to return internal host data IDs: CVE-2023-42439, GHSA-pxg5-h34r-7q8p Record: https://patchnext.com/advisories/cve-2023-42439 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: geonode 4.1.3.post1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI geonode: affected >= 3.2.0, <= 4.1.2; fixed in 4.1.3.post1 ## Suggested inspection (read-only) - `python -m pip show geonode`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on geonode. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pxg5-h34r-7q8p (OSV record GHSA-pxg5-h34r-7q8p lists affected ranges: PyPI geonode >=3.2.0 <4.1.3.post1 (fixed)) - Verified: https://github.com/advisories/GHSA-pxg5-h34r-7q8p (GitHub-reviewed advisory GHSA-pxg5-h34r-7q8p lists affected ranges: PyPI geonode >=3.2.0 <=4.1.2) Commands are suggestions: review each one before running it.
Loading voting…