Alkacon OpenCms is vulnerable to XSS via cmis-online/type
CVE-2023-42343GHSA-8gpv-c454-3hfc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencms:opencms-core 16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opencms:opencms-core
- Affected
- < 16.0
- Fixed in
- 16.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8gpv-c454-3hfc lists affected ranges: Maven org.opencms:opencms-core >=0 <16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-42343: 0.59% estimated exploitation activity in the next 30 days; percentile 48.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross Site Scripting vulnerability in Alkacon OpenCms before 10.5.1 exists via cmis-online/type.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8gpv-c454-3hfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-42343 Advisory: Alkacon OpenCms is vulnerable to XSS via cmis-online/type IDs: CVE-2023-42343, GHSA-8gpv-c454-3hfc Record: https://patchnext.com/advisories/cve-2023-42343 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opencms:opencms-core 16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opencms:opencms-core: affected < 16.0; fixed in 16.0 ## Suggested inspection (read-only) - Maven org.opencms:opencms-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opencms:opencms-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8gpv-c454-3hfc (GitHub-reviewed advisory GHSA-8gpv-c454-3hfc lists affected ranges: Maven org.opencms:opencms-core >=0 <16.0) Commands are suggestions: review each one before running it.
Loading voting…