Eclipse IDE XXE in eclipse.platform
CVE-2023-4218GHSA-j24h-xcpc-9jw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jdt:org.eclipse.jdt.ui 3.30.0; org.eclipse.platform:org.eclipse.core.runtime 3.29.0; org.eclipse.platform:org.eclipse.ui.workbench 3.130.0; org.eclipse.platform:org.eclipse.jface 3.31.0; org.eclipse.platform:org.eclipse.platform 4.29.0; 3 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jdt:org.eclipse.jdt.ui
- Affected
- < 3.30.0
- Fixed in
- 3.30.0
Maven org.eclipse.platform:org.eclipse.core.runtime
- Affected
- < 3.29.0
- Fixed in
- 3.29.0
Maven org.eclipse.platform:org.eclipse.ui.workbench
- Affected
- < 3.130.0
- Fixed in
- 3.130.0
Maven org.eclipse.platform:org.eclipse.jface
- Affected
- < 3.31.0
- Fixed in
- 3.31.0
Maven org.eclipse.platform:org.eclipse.platform
- Affected
- < 4.29.0
- Fixed in
- 4.29.0
Maven org.eclipse.platform:org.eclipse.urischeme
- Affected
- < 1.3.100
- Fixed in
- 1.3.100
Maven org.eclipse.platform:org.eclipse.ui.forms
- Affected
- < 3.13.0
- Fixed in
- 3.13.0
Maven org.eclipse.platform:org.eclipse.ui.ide
- Affected
- < 3.21.100
- Fixed in
- 3.21.100
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j24h-xcpc-9jw8 lists affected ranges: Maven org.eclipse.platform:org.eclipse.core.runtime >=0 =0 =0 =0 =0 =0 =0…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-4218: 0.39% estimated exploitation activity in the next 30 days; percentile 33.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact xml files like ".project" are parsed vulnerable against all sorts of XXE attacks. The user just needs to open any evil project or update an open project with a vulnerable file (for example for review a foreign repository or patch). Vulnerablility was found by static code analysis (SonarLint). Example .project file: Patches Similar patches including junit test that shows the vulnerability have already applied to PDE (see https://github.com/eclipse-pde/eclipse.pde/pull/667). A solution to platform should be the same: just reject parsing any XML that contains any DOCTYPE. Workarounds No known workaround. User can only avoid to get/open any foreign files with eclipse. Firewall rules against loss of data (but not against XML bomb). References https://cwe.mitre.org/data/definitions/611.html https://rules.sonarsource.com/java/RSPEC-2755 https://gitlab.eclipse.org/security/vulnerability-reports/-/issues/8 (Report for multiple projects affected)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j24h-xcpc-9jw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-4218 Advisory: Eclipse IDE XXE in eclipse.platform IDs: CVE-2023-4218, GHSA-j24h-xcpc-9jw8 Record: https://patchnext.com/advisories/cve-2023-4218 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jdt:org.eclipse.jdt.ui 3.30.0; org.eclipse.platform:org.eclipse.core.runtime 3.29.0; org.eclipse.platform:org.eclipse.ui.workbench 3.130.0; org.eclipse.platform:org.eclipse.jface 3.31.0; org.eclipse.platform:org.eclipse.platform 4.29.0; org.eclipse.platform:org.eclipse.urischeme 1.3.100; org.eclipse.platform:org.eclipse.ui.forms 3.13.0; org.eclipse.platform:org.eclipse.ui.ide 3.21.100. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jdt:org.eclipse.jdt.ui: affected < 3.30.0; fixed in 3.30.0 - Maven org.eclipse.platform:org.eclipse.core.runtime: affected < 3.29.0; fixed in 3.29.0 - Maven org.eclipse.platform:org.eclipse.ui.workbench: affected < 3.130.0; fixed in 3.130.0 - Maven org.eclipse.platform:org.eclipse.jface: affected < 3.31.0; fixed in 3.31.0 - Maven org.eclipse.platform:org.eclipse.platform: affected < 4.29.0; fixed in 4.29.0 - Maven org.eclipse.platform:org.eclipse.urischeme: affected < 1.3.100; fixed in 1.3.100 - Maven org.eclipse.platform:org.eclipse.ui.forms: affected < 3.13.0; fixed in 3.13.0 - Maven org.eclipse.platform:org.eclipse.ui.ide: affected < 3.21.100; fixed in 3.21.100 ## Suggested inspection (read-only) - Maven org.eclipse.jdt:org.eclipse.jdt.ui: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.core.runtime: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.ui.workbench: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.jface: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.platform: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.urischeme: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.ui.forms: check the installed version with your package manager. - Maven org.eclipse.platform:org.eclipse.ui.ide: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jdt:org.eclipse.jdt.ui, org.eclipse.platform:org.eclipse.core.runtime, org.eclipse.platform:org.eclipse.ui.workbench, org.eclipse.platform:org.eclipse.jface, org.eclipse.platform:org.eclipse.platform, org.eclipse.platform:org.eclipse.urischeme, org.eclipse.platform:org.eclipse.ui.forms, org.eclipse.platform:org.eclipse.ui.ide. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j24h-xcpc-9jw8 (GitHub-reviewed advisory GHSA-j24h-xcpc-9jw8 lists affected ranges: Maven org.eclipse.platform:org.eclipse.core.runtime >=0 =0 =0 =0 =0 =0 =0…) Commands are suggestions: review each one before running it.
Loading voting…