Cockpit Cross-site Scripting vulnerability
CVE-2023-4196GHSA-w3qm-93vf-5hrw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cockpit-hq/cockpit 2.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cockpit-hq/cockpit
- Affected
- < 2.6.3
- Fixed in
- 2.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3qm-93vf-5hrw lists affected ranges: Packagist cockpit-hq/cockpit >=0 <2.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2023-4196: 0.47% estimated exploitation activity in the next 30 days; percentile 40.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site Scripting (XSS) - Stored in GitHub repository cockpit-hq/cockpit prior to 2.6.3. For any role that has permission to execute function assets, an attacker can upload a html file and that leads to XSS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w3qm-93vf-5hrw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-4196 Advisory: Cockpit Cross-site Scripting vulnerability IDs: CVE-2023-4196, GHSA-w3qm-93vf-5hrw Record: https://patchnext.com/advisories/cve-2023-4196 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cockpit-hq/cockpit 2.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cockpit-hq/cockpit: affected < 2.6.3; fixed in 2.6.3 ## Suggested inspection (read-only) - Packagist cockpit-hq/cockpit: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cockpit-hq/cockpit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3qm-93vf-5hrw (GitHub-reviewed advisory GHSA-w3qm-93vf-5hrw lists affected ranges: Packagist cockpit-hq/cockpit >=0 <2.6.3) Commands are suggestions: review each one before running it.
Loading voting…