Jetty's OpenId Revoked authentication allows one request
CVE-2023-41900GHSA-pwh8-58vv-vw48
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-openid 11.0.16, 10.0.16, 9.4.52.v20230823), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty:jetty-openid
- Affected
- >= 9.4.21, <= 9.4.51>= 10.0.0, <= 10.0.15>= 11.0.0, <= 11.0.15
- Fixed in
- 10.0.16, 9.4.52.v20230823, 11.0.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pwh8-58vv-vw48 lists affected ranges: Maven org.eclipse.jetty:jetty-openid >=9.4.21 =10.0.0 =11.0.0 <=11.0.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2023-41900: 0.91% estimated exploitation activity in the next 30 days; percentile 60.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
If a Jetty OpenIdAuthenticator uses the optional nested LoginService, and that LoginService decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the LoginService. Impact This impacts usages of the jetty-openid which have configured a nested LoginService and where that LoginService will is capable of rejecting previously authenticated users. Original Report working on a custom OpenIdAuthenticator, I discovered the following: https://github.com/eclipse/jetty.project/blob/jetty-10.0.14/jetty-openid/src/main/java/org/eclipse/jetty/security/openid/OpenIdAuthenticator.java#L505 In the case where the LoginService does return that the authentication has been revoked (from the validate() call on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pwh8-58vv-vw48
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41900 Advisory: Jetty's OpenId Revoked authentication allows one request IDs: CVE-2023-41900, GHSA-pwh8-58vv-vw48 Record: https://patchnext.com/advisories/cve-2023-41900 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-openid 11.0.16, 10.0.16, 9.4.52.v20230823. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty:jetty-openid: affected >= 9.4.21, <= 9.4.51; >= 10.0.0, <= 10.0.15; >= 11.0.0, <= 11.0.15; fixed in 10.0.16, 9.4.52.v20230823, 11.0.16 ## Suggested inspection (read-only) - Maven org.eclipse.jetty:jetty-openid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty:jetty-openid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pwh8-58vv-vw48 (GitHub-reviewed advisory GHSA-pwh8-58vv-vw48 lists affected ranges: Maven org.eclipse.jetty:jetty-openid >=9.4.21 =10.0.0 =11.0.0 <=11.0.15) Commands are suggestions: review each one before running it.
Loading voting…