Skip to content

← Actionable
Medium, CVSS 5.1amended

Home Assistant vulnerable to account takeover via auth_callback login

CVE-2023-41893GHSA-qhhj-7hrc-gqj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (homeassistant 2023.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-41893: 0.45% estimated exploitation activity in the next 30 days; percentile 39.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Part of the Cure53 security audit of Home Assistant. The audit team’s analyses confirmed that the redirecturi and clientid are alterable when logging in. Consequently, the code parameter utilized to fetch the accesstoken post-authentication will be sent to the URL specified in the aforementioned parameters. Since an arbitrary URL is permitted and homeassistant.local represents the preferred, default domain likely used and trusted by many users, an attacker could leverage this weakness to manipulate a user and retrieve account access. Notably, this attack strategy is plausible if the victim has exposed their Home Assistant to the Internet, since after acquiring the victim’s accesstoken, the adversary would need to utilize it directly towards the instance to achieve any pertinent malicious actions. To achieve this compromise attempt, the attacker must send a link with a redirecturi that they control to the victim’s own Home Assistant instance. In the eventuality the victim…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qhhj-7hrc-gqj5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qhhj-7hrc-gqj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41893

Advisory: Home Assistant vulnerable to account takeover via auth_callback login
IDs: CVE-2023-41893, GHSA-qhhj-7hrc-gqj5
Record: https://patchnext.com/advisories/cve-2023-41893 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: homeassistant 2023.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI homeassistant: affected < 2023.9.0; fixed in 2023.9.0

## Suggested inspection (read-only)
- `python -m pip show homeassistant`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on homeassistant.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qhhj-7hrc-gqj5 (OSV record GHSA-qhhj-7hrc-gqj5 lists affected ranges: PyPI homeassistant >=0 <2023.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qhhj-7hrc-gqj5 (GitHub-reviewed advisory GHSA-qhhj-7hrc-gqj5 lists affected ranges: PyPI homeassistant >=0 <2023.9.0)

Commands are suggestions: review each one before running it.

Loading voting…