Flyte Admin SQL Injection in List Filters
CVE-2023-41891GHSA-r847-6w6h-r8g4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/flyteorg/flyteadmin 1.1.124), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/flyteorg/flyteadmin
- Affected
- < 1.1.124
- Fixed in
- 1.1.124
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r847-6w6h-r8g4 lists affected ranges: Go github.com/flyteorg/flyteadmin >=0 <1.1.124
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-41891: 1.06% estimated exploitation activity in the next 30 days; percentile 64.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact List endpoints on Flyte Admin has a SQL vulnerability where a malicious user can send a REST requests with custom SQL statements as list filters. Workarounds The attacker needs to have access to the flyteadmin installation (typically either behind a VPN or authentication). References https://owasp.org/www-community/attacks/SQLInjection#
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r847-6w6h-r8g4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41891 Advisory: Flyte Admin SQL Injection in List Filters IDs: CVE-2023-41891, GHSA-r847-6w6h-r8g4 Record: https://patchnext.com/advisories/cve-2023-41891 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/flyteorg/flyteadmin 1.1.124. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/flyteorg/flyteadmin: affected < 1.1.124; fixed in 1.1.124 ## Suggested inspection (read-only) - Go github.com/flyteorg/flyteadmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/flyteorg/flyteadmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r847-6w6h-r8g4 (GitHub-reviewed advisory GHSA-r847-6w6h-r8g4 lists affected ranges: Go github.com/flyteorg/flyteadmin >=0 <1.1.124) Commands are suggestions: review each one before running it.
Loading voting…