Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation
CVE-2023-41890GHSA-fv2h-753j-9g39
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet kentor.authservices
- Affected
- <= 0.23.0
- Fixed in
- no fixed version recorded
NuGet sustainsys.saml2
- Affected
- < 1.0.3>= 2.0.0, < 2.9.2
- Fixed in
- 2.9.2, 1.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fv2h-753j-9g39 lists affected ranges: NuGet sustainsys.saml2 >=0 =2.0.0 =0 <=0.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-41890: 0.75% estimated exploitation activity in the next 30 days; percentile 55.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims items in the stored request state (AuthenticationProperties) Patches Patched in version 2.9.2 and 1.0.3. All previous versions are vulnerable. Workarounds The AcsCommandResultCreated notification can be used to add the validation required if an upgrade to patched packages is not possible. References The patch is linked to https://github.com/Sustainsys/Saml2/issues/712 and https://github.com/Sustainsys/Saml2/issues/713
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fv2h-753j-9g39
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41890 Advisory: Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation IDs: CVE-2023-41890, GHSA-fv2h-753j-9g39 Record: https://patchnext.com/advisories/cve-2023-41890 (revision 1, source checked 26 Oct 2026, 17:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: sustainsys.saml2 2.9.2, 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet kentor.authservices: affected <= 0.23.0 - NuGet sustainsys.saml2: affected < 1.0.3; >= 2.0.0, < 2.9.2; fixed in 2.9.2, 1.0.3 ## Suggested inspection (read-only) - NuGet kentor.authservices: check the installed version with your package manager. - NuGet sustainsys.saml2: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kentor.authservices, sustainsys.saml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fv2h-753j-9g39 (GitHub-reviewed advisory GHSA-fv2h-753j-9g39 lists affected ranges: NuGet sustainsys.saml2 >=0 =2.0.0 =0 <=0.23.0) Commands are suggestions: review each one before running it.
Loading voting…