Skip to content

← Actionable
Critical, CVSS 9.8

OpenRefine Remote Code execution in project import with mysql jdbc url attack

CVE-2023-41887GHSA-p3r5-x3hr-gpg5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openrefine:database 3.7.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-41887: 42.54% estimated exploitation activity in the next 30 days; percentile 98.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An remote Code exec vulnerability allows any unauthenticated user to exec code on the server. Details Hi,Team, i find openrefine support to import data from database,When use mysql jdbc to connect to database,It is vulnerable to jdbc url attacks,for example,unauthenticated attacker can get rce on the server through the mysql userializable If the mysql-connector-java version used on the server side is less than 8.20. In order for the server to enable deserialization we need to set the autoDeserialize and queryInterceptors parameters in the connection string,As same with https://github.com/OpenRefine/OpenRefine/security/advisories/GHSA-qqh2-wvmv-h72m, since the concatenation string is a direct concatenation, it is possible to inject the required parameters after the other parameters. And there is a commons-beanutils dependency library on the server side, which contains an RCE-capable deserialization exploit chain PoC env: centos 7 openrefine 3.7.4 jdk11 mysql-connector-java…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p3r5-x3hr-gpg5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41887

Advisory: OpenRefine Remote Code execution in project import with mysql jdbc url attack
IDs: CVE-2023-41887, GHSA-p3r5-x3hr-gpg5
Record: https://patchnext.com/advisories/cve-2023-41887 (revision 1, source checked 26 Oct 2026, 16:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.openrefine:database 3.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.openrefine:database: affected <= 3.7.4; fixed in 3.7.5

## Suggested inspection (read-only)
- Maven org.openrefine:database: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.openrefine:database.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p3r5-x3hr-gpg5 (GitHub-reviewed advisory GHSA-p3r5-x3hr-gpg5 lists affected ranges: Maven org.openrefine:database >=0 <=3.7.4)

Commands are suggestions: review each one before running it.

Loading voting…