omeka/omeka-s Improper Input Validation vulnerability
CVE-2023-4157GHSA-fxc5-pr68-2px3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (omeka/omeka-s 4.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist omeka/omeka-s
- Affected
- < 4.0.3
- Fixed in
- 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fxc5-pr68-2px3 lists affected ranges: Packagist omeka/omeka-s >=0 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.2 · CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-4157: 0.51% estimated exploitation activity in the next 30 days; percentile 43.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation in GitHub repository omeka/omeka-s prior to 4.0.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fxc5-pr68-2px3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-4157 Advisory: omeka/omeka-s Improper Input Validation vulnerability IDs: CVE-2023-4157, GHSA-fxc5-pr68-2px3 Record: https://patchnext.com/advisories/cve-2023-4157 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: omeka/omeka-s 4.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist omeka/omeka-s: affected < 4.0.3; fixed in 4.0.3 ## Suggested inspection (read-only) - Packagist omeka/omeka-s: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on omeka/omeka-s. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fxc5-pr68-2px3 (GitHub-reviewed advisory GHSA-fxc5-pr68-2px3 lists affected ranges: Packagist omeka/omeka-s >=0 <4.0.3) Commands are suggestions: review each one before running it.
Loading voting…