Unsecured WMS dynamic styling sld= parameter affords blind unauthenticated SSRF
CVE-2023-41339GHSA-cqpc-x2c6-2gmf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.web:gs-web-app 2.23.2, 2.22.5; org.geoserver:gs-wms 2.23.2, 2.22.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver.web:gs-web-app
- Affected
- < 2.22.5>= 2.23.0, < 2.23.2
- Fixed in
- 2.22.5, 2.23.2
Maven org.geoserver:gs-wms
- Affected
- < 2.22.5>= 2.23.0, < 2.23.2
- Fixed in
- 2.22.5, 2.23.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cqpc-x2c6-2gmf lists affected ranges: Maven org.geoserver:gs-wms >=0 =2.23.0 =0 =2.23.0 <2.23.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-41339: 0.63% estimated exploitation activity in the next 30 days; percentile 50.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The WMS specification defines an sld=<url parameter for GetMap, GetLegendGraphic and GetFeatureInfo operations for user supplied "dynamic styling". Enabling the use of dynamic styles, without also configuring URL checks, provides the opportunity for Service Side Request Forgery. It is possible to use this for "Blind SSRF" on the WMS endpoint to steal NetNTLMv2 hashes via file requests to malicious servers. Details This vulnerability requires: WMS Settings dynamic styling being enabled Security URL checks to be disabled, or to be enabled and allowing file:\\ access Impact This vulnerability can be used to steal user NetNTLMv2 hashes which could be relayed or cracked externally to gain further access. Mitigation The ability to reference an external URL location is defined by the WMS standard GetMap, GetFeatureInfo and GetLegendGraphic operations. These operations are defined by an Industry and International standard and cannot be redefined by the GeoServer application in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cqpc-x2c6-2gmf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41339 Advisory: Unsecured WMS dynamic styling sld= parameter affords blind unauthenticated SSRF IDs: CVE-2023-41339, GHSA-cqpc-x2c6-2gmf Record: https://patchnext.com/advisories/cve-2023-41339 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver.web:gs-web-app 2.23.2, 2.22.5; org.geoserver:gs-wms 2.23.2, 2.22.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver.web:gs-web-app: affected < 2.22.5; >= 2.23.0, < 2.23.2; fixed in 2.22.5, 2.23.2 - Maven org.geoserver:gs-wms: affected < 2.22.5; >= 2.23.0, < 2.23.2; fixed in 2.22.5, 2.23.2 ## Suggested inspection (read-only) - Maven org.geoserver.web:gs-web-app: check the installed version with your package manager. - Maven org.geoserver:gs-wms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver.web:gs-web-app, org.geoserver:gs-wms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cqpc-x2c6-2gmf (GitHub-reviewed advisory GHSA-cqpc-x2c6-2gmf lists affected ranges: Maven org.geoserver:gs-wms >=0 =2.23.0 =0 =2.23.0 <2.23.2) Commands are suggestions: review each one before running it.
Loading voting…