Skip to content

← Actionable
Medium, CVSS 6.5

Prevent injection of invalid entity ids for "autocomplete" fields

CVE-2023-41336GHSA-4cpv-669c-r79x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/ux-autocomplete 2.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2023-41336: 0.64% estimated exploitation activity in the next 30 days; percentile 50.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Under certain circumstances, an attacker could successfully submit an entity id for an EntityType that is not part of the valid choices. Affected applications are any that use: A custom querybuilder option to limit the valid results; AND An EntityType with 'autocomplete' = true or a custom AsEntityAutocompleteField. Under this circumstance, if an id is submitted, it is accepted even if the matching record would not be returned by the custom query built with querybuilder. Patches The problem has been fixed in symfony/ux-autocomplete version 2.11.2. Workarounds Upgrade to version 2.11.2 or greater of symfony/ux-autocomplete or perform extra validation after submit to verify the selected option is valid.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4cpv-669c-r79x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41336

Advisory: Prevent injection of invalid entity ids for "autocomplete" fields
IDs: CVE-2023-41336, GHSA-4cpv-669c-r79x
Record: https://patchnext.com/advisories/cve-2023-41336 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/ux-autocomplete 2.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/ux-autocomplete: affected < 2.11.2; fixed in 2.11.2

## Suggested inspection (read-only)
- Packagist symfony/ux-autocomplete: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/ux-autocomplete.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4cpv-669c-r79x (GitHub-reviewed advisory GHSA-4cpv-669c-r79x lists affected ranges: Packagist symfony/ux-autocomplete >=0 <2.11.2)

Commands are suggestions: review each one before running it.

Loading voting…