matrix-synapse vulnerable to temporary storage of plaintext passwords during password changes
CVE-2023-41335GHSA-4f74-84v3-j9q5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.93.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- >= 1.66.0, < 1.93.0
- Fixed in
- 1.93.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4f74-84v3-j9q5 lists affected ranges: PyPI matrix-synapse >=1.66.0 <1.93.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4f74-84v3-j9q5 lists affected ranges: PyPI matrix-synapse >=1.66.0 <1.93.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-41335: 0.39% estimated exploitation activity in the next 30 days; percentile 32.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When users update their passwords, the new credentials may be briefly held in the server database. While this doesn't grant the server any added capabilities—it already learns the users' passwords as part of the authentication process—it does disrupt the expectation that passwords won't be stored in the database. As a result, these passwords could inadvertently be captured in database backups for a longer duration. These temporarily stored passwords are automatically erased after a 48-hour window. Patches https://github.com/matrix-org/synapse/pull/16272 References This bug was due to a regression in https://github.com/matrix-org/synapse/pull/13188.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4f74-84v3-j9q5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4f74-84v3-j9q5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41335 Advisory: matrix-synapse vulnerable to temporary storage of plaintext passwords during password changes IDs: CVE-2023-41335, GHSA-4f74-84v3-j9q5 Record: https://patchnext.com/advisories/cve-2023-41335 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.93.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected >= 1.66.0, < 1.93.0; fixed in 1.93.0 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4f74-84v3-j9q5 (OSV record GHSA-4f74-84v3-j9q5 lists affected ranges: PyPI matrix-synapse >=1.66.0 <1.93.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4f74-84v3-j9q5 (GitHub-reviewed advisory GHSA-4f74-84v3-j9q5 lists affected ranges: PyPI matrix-synapse >=1.66.0 <1.93.0) Commands are suggestions: review each one before running it.
Loading voting…