Cilium vulnerable to bypass of namespace restrictions in CiliumNetworkPolicy
CVE-2023-41333GHSA-4xp2-w642-7mcx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.14.2, 1.13.7, 1.12.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.14.0, < 1.14.2>= 1.13.0, < 1.13.7< 1.12.14
- Fixed in
- 1.12.14, 1.14.2, 1.13.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4xp2-w642-7mcx lists affected ranges: Go github.com/cilium/cilium >=1.14.0 =1.13.0 =0 <1.12.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.9 · CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:H
- EPSS
- CVE-2023-41333: 0.48% estimated exploitation activity in the next 30 days; percentile 41.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker with the ability to create or modify CiliumNetworkPolicy objects in a particular namespace is able to affect traffic on an entire Cilium cluster, potentially bypassing policy enforcement in other namespaces. By using a crafted endpointSelector that uses the DoesNotExist operator on the reserved:init label, the attacker can create policies that bypass namespace restrictions and affect the entire Cilium cluster. This includes potentially allowing or denying all traffic. This attack requires API server access, as described in the Kubernetes API Server Attacker section of the Cilium Threat Model. Patches This issue was patched in https://github.com/cilium/cilium/pull/28007 This issue affects: - Cilium <= v1.14.1 - Cilium <= v1.13.6 - Cilium <= v1.12.13 This issue has been resolved in: - Cilium v1.14.2 - Cilium v1.13.7 - Cilium v1.12.14 Workarounds An admission webhook can be used to prevent the use of endpointSelectors that use the DoesNotExist operator on the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4xp2-w642-7mcx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41333 Advisory: Cilium vulnerable to bypass of namespace restrictions in CiliumNetworkPolicy IDs: CVE-2023-41333, GHSA-4xp2-w642-7mcx Record: https://patchnext.com/advisories/cve-2023-41333 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.14.2, 1.13.7, 1.12.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cilium/cilium: affected >= 1.14.0, < 1.14.2; >= 1.13.0, < 1.13.7; < 1.12.14; fixed in 1.12.14, 1.14.2, 1.13.7 ## Suggested inspection (read-only) - Go github.com/cilium/cilium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cilium/cilium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4xp2-w642-7mcx (GitHub-reviewed advisory GHSA-4xp2-w642-7mcx lists affected ranges: Go github.com/cilium/cilium >=1.14.0 =1.13.0 =0 <1.12.14) Commands are suggestions: review each one before running it.
Loading voting…