Skip to content

← Actionable
Low, CVSS 3.5

Specific Cilium configurations vulnerable to DoS via Kubernetes annotations

CVE-2023-41332GHSA-24m5-r6hv-ccgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.14.2, 1.13.7, 1.12.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2023-41332: 0.51% estimated exploitation activity in the next 30 days; percentile 43.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Cilium clusters where Cilium's Layer 7 proxy has been disabled, creating workloads with - policy.cilium.io/proxy-visibility annotations (in Cilium = v1.13) - io.cilium.proxy-visibility annotations (in Cilium <= v1.12) causes the Cilium agent to segfault on the node to which the workload is assigned. Existing traffic on the affected node will continue to flow, but the Cilium agent on the node will not able to process changes to workloads running on the node. This will also prevent workloads from being able to start on the affected node. The denial of service will be limited to the node on which the workload is scheduled, however an attacker may be able to schedule workloads on the node of their choosing, which could lead to targeted attacks. Patches Pull request with fix This issue affects: Cilium <= v1.14.1 Cilium <= v1.13.6 Cilium <= v1.12.13 This issue has been resolved in: Cilium v1.14.2 Cilium v1.13.7 Cilium v1.12.14 Workarounds Users can avoid this denial of service…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-24m5-r6hv-ccgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41332

Advisory: Specific Cilium configurations vulnerable to DoS via Kubernetes annotations
IDs: CVE-2023-41332, GHSA-24m5-r6hv-ccgp
Record: https://patchnext.com/advisories/cve-2023-41332 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.14.2, 1.13.7, 1.12.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cilium/cilium: affected >= 1.14.0, < 1.14.2; < 1.12.14; >= 1.13.0, < 1.13.7; fixed in 1.12.14, 1.14.2, 1.13.7

## Suggested inspection (read-only)
- Go github.com/cilium/cilium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cilium/cilium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-24m5-r6hv-ccgp (GitHub-reviewed advisory GHSA-24m5-r6hv-ccgp lists affected ranges: Go github.com/cilium/cilium >=1.14.0 =0 =1.13.0 <1.13.7)

Commands are suggestions: review each one before running it.

Loading voting…