Snappy PHAR deserialization vulnerability
CVE-2023-41330GHSA-92rv-4j2h-8mjj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (knplabs/knp-snappy 1.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist knplabs/knp-snappy
- Affected
- <= 1.4.2
- Fixed in
- 1.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92rv-4j2h-8mjj lists affected ranges: Packagist knplabs/knp-snappy >=0 <=1.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-41330: 2.29% estimated exploitation activity in the next 30 days; percentile 83.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Issue On March 17th the vulnerability CVE-2023-28115 was disclosed, allowing an attacker to gain remote code execution through PHAR deserialization. To fix this issue, the version 1.4.2 was released with an additional check in the affected function to prevent the usage of the phar:// wrapper. However, because PHP wrappers are case-insensitive and the patch only checks the presence of the phar:// string, it can be bypassed to achieve remote code execution again using a different case. As for the initial vulnerability, PHP 7 or below is required for a successful exploitation using the deserialization of PHP archives metadata via the phar:// wrapper. Technical details Description The following patch was committed on the 1.4.2 release to fix CVE-2023-28115. If the user is able to control the second parameter of the generateFromHtml() function of Snappy, it will then be passed as the $filename parameter in the prepareOutput() function. In the original vulnerability, a file name with a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-92rv-4j2h-8mjj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41330 Advisory: Snappy PHAR deserialization vulnerability IDs: CVE-2023-41330, GHSA-92rv-4j2h-8mjj Record: https://patchnext.com/advisories/cve-2023-41330 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: knplabs/knp-snappy 1.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist knplabs/knp-snappy: affected <= 1.4.2; fixed in 1.4.3 ## Suggested inspection (read-only) - Packagist knplabs/knp-snappy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on knplabs/knp-snappy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-92rv-4j2h-8mjj (GitHub-reviewed advisory GHSA-92rv-4j2h-8mjj lists affected ranges: Packagist knplabs/knp-snappy >=0 <=1.4.2) Commands are suggestions: review each one before running it.
Loading voting…