Skip to content

← Actionable
High, CVSS 8.8amended

Remote Code Execution in Custom Integration Upload

CVE-2023-41319GHSA-p6p2-qq95-vq5h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-41319: 0.94% estimated exploitation activity in the next 30 days; percentile 60.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Fides webserver API allows custom integrations to be uploaded as a ZIP file. This ZIP file must contain YAML files, but Fides can be configured to also accept the inclusion of custom Python code in it. The custom code is executed in a restricted, sandboxed environment, but the sandbox can be bypassed to execute any arbitrary code. The vulnerability allows the execution of arbitrary code on the target system within the context of the webserver python process owner on the webserver container, which by default is root, and leverage that access to attack underlying infrastructure and integrated systems. This vulnerability affects Fides versions 2.11.0 through 2.18.0. Exploitation is limited to API clients with the CONNECTORTEMPLATEREGISTER authorization scope. In the Fides Admin UI this scope is restricted to highly privileged users, specifically root users and users with the owner role. Exploitation is only possible if the security configuration parameter…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p6p2-qq95-vq5h

  2. Revision 1 · created ·

    Published from osv record GHSA-p6p2-qq95-vq5h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41319

Advisory: Remote Code Execution in Custom Integration Upload
IDs: CVE-2023-41319, GHSA-p6p2-qq95-vq5h
Record: https://patchnext.com/advisories/cve-2023-41319 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected >= 2.11.0, < 2.19.0; fixed in 2.19.0

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p6p2-qq95-vq5h (OSV record GHSA-p6p2-qq95-vq5h lists affected ranges: PyPI ethyca-fides >=2.11.0 <2.19.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p6p2-qq95-vq5h (GitHub-reviewed advisory GHSA-p6p2-qq95-vq5h lists affected ranges: PyPI ethyca-fides >=2.11.0 <2.19.0)

Commands are suggestions: review each one before running it.

Loading voting…