Skip to content

← Actionable
Medium, CVSS 5.9

Apollo Router Unnamed "Subscription" operation results in Denial-of-Service

CVE-2023-41317GHSA-w8vq-3hf9-xppx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-router 1.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io apollo-router

    Affected
    >= 1.28.0, <= 1.29.0
    Fixed in
    1.29.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-41317: 0.80% estimated exploitation activity in the next 30 days; percentile 56.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when GraphQL Subscriptions are enabled. It can be triggered when all of the following conditions are met: 1. Running Apollo Router v1.28.0, v1.28.1 or v1.29.0 ("impacted versions"); and 2. The Supergraph schema provided to the Router (either via Apollo Uplink or explicitly via other configuration) has a subscription type with root-fields defined; and 3. The YAML configuration provided to the Router has subscriptions enabled (they are disabled by default), either by setting enabled: true or by setting a valid mode within the subscriptions object (as seen in subscriptions' documentation); and 4. An anonymous (i.e., un-named) subscription operation (e.g., subscription { ... }) is received by the Router If all four of these criteria are met, the impacted versions will panic and terminate. There is no data-privacy risk or sensitive-information exposure aspect to this vulnerability.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w8vq-3hf9-xppx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41317

Advisory: Apollo Router Unnamed "Subscription" operation results in Denial-of-Service
IDs: CVE-2023-41317, GHSA-w8vq-3hf9-xppx
Record: https://patchnext.com/advisories/cve-2023-41317 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apollo-router 1.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io apollo-router: affected >= 1.28.0, <= 1.29.0; fixed in 1.29.1

## Suggested inspection (read-only)
- crates.io apollo-router: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apollo-router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w8vq-3hf9-xppx (GitHub-reviewed advisory GHSA-w8vq-3hf9-xppx lists affected ranges: crates.io apollo-router >=1.28.0 <=1.29.0)

Commands are suggestions: review each one before running it.

Loading voting…