Skip to content

← Actionable
Medium, CVSS 4.8amended

@webiny/react-rich-text-renderer vulnerable to insecure rendering of rich text content

CVE-2023-41167GHSA-3x59-vrmc-5mx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@webiny/react-rich-text-renderer 5.37.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-41167: 0.39% estimated exploitation activity in the next 30 days; percentile 33.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview @webiny/react-rich-text-renderer is a react component to render data coming from Webiny Headless CMS and Webiny Form Builder. The @webiny/react-rich-text-renderer package depends on the editor.js rich text editor to handle rich text content. The CMS stores rich text content from the editor.js into the database. When the @webiny/react-rich-text-renderer is used to render such content, it uses the dangerouslySetInnerHTML prop, without applying HTML sanitization. The issue arises when an actor, who in this context would specifically be a content manager with access to the CMS, inserts a malicious script as part of the user-defined input. This script is then injected and executed within the user's browser when the main page or admin page loads. Am I affected? You will be affected if you're running a Webiny project created prior to 5.35.0 and you're using the legacy rich text editor (which uses editor.js library under the hood). If you've already switched to using the new rich…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3x59-vrmc-5mx6

  2. Revision 1 · created ·

    Published from osv record GHSA-3x59-vrmc-5mx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41167

Advisory: @webiny/react-rich-text-renderer vulnerable to insecure rendering of rich text content
IDs: CVE-2023-41167, GHSA-3x59-vrmc-5mx6
Record: https://patchnext.com/advisories/cve-2023-41167 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @webiny/react-rich-text-renderer 5.37.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @webiny/react-rich-text-renderer: affected <= 5.37.1; fixed in 5.37.2

## Suggested inspection (read-only)
- `npm ls @webiny/react-rich-text-renderer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @webiny/react-rich-text-renderer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3x59-vrmc-5mx6 (OSV record GHSA-3x59-vrmc-5mx6 lists affected ranges: npm @webiny/react-rich-text-renderer >=0 <5.37.2 (fixed))
- Verified: https://github.com/advisories/GHSA-3x59-vrmc-5mx6 (GitHub-reviewed advisory GHSA-3x59-vrmc-5mx6 lists affected ranges: npm @webiny/react-rich-text-renderer >=0 <=5.37.1)

Commands are suggestions: review each one before running it.

Loading voting…