Skip to content

← Actionable
High, CVSS 7.5amended

Trigger beforeFind not invoked in internal query pipeline when fetching pointer

CVE-2023-41058GHSA-fcv6-fg5r-jm9q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 6.2.2, 5.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 1.0.0, < 5.5.5>= 6.0.0, < 6.2.2
    Fixed in
    5.5.5, 6.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-41058: 0.77% estimated exploitation activity in the next 30 days; percentile 55.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Parse Pointer can be used to access internal Parse Server classes. It can also be used to circumvent the beforeFind query trigger which can be an additional vulnerability for deployments where the beforeFind trigger is used as a security layer to modify an incoming query. Patches The vulnerability was fixed by implementing a patch in the internal query pipeline to prevent a Parse Pointer to be used to access internal Parse Server classes or circumvent the beforeFind trigger. Workarounds There is no known workaround to prevent a Parse Pointer to be used to access internal Parse Server classes. A workaround if a beforeFind trigger is used as a security layer is to instead use the Parse Server provided security layers to manage access levels with Class-Level Permissions and Object-Level Access Control. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-fcv6-fg5r-jm9q - Patched in Parse Server 6.x:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fcv6-fg5r-jm9q

  2. Revision 1 · created ·

    Published from osv record GHSA-fcv6-fg5r-jm9q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41058

Advisory: Trigger `beforeFind` not invoked in internal query pipeline when fetching pointer
IDs: CVE-2023-41058, GHSA-fcv6-fg5r-jm9q
Record: https://patchnext.com/advisories/cve-2023-41058 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 6.2.2, 5.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 1.0.0, < 5.5.5; >= 6.0.0, < 6.2.2; fixed in 5.5.5, 6.2.2

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fcv6-fg5r-jm9q (OSV record GHSA-fcv6-fg5r-jm9q lists affected ranges: npm parse-server >=1.0.0 =6.0.0 <6.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-fcv6-fg5r-jm9q (GitHub-reviewed advisory GHSA-fcv6-fg5r-jm9q lists affected ranges: npm parse-server >=1.0.0 =6.0.0 <6.2.2)

Commands are suggestions: review each one before running it.

Loading voting…